ECSHOP 出现\includes\lib_common.php on line 959错误解决办法

老服务器报废了,最近新买了台IBM服务器,装了个Centos6.0 yum里是php5.3的版本。将原来的ECSHOP程序覆盖后,一切正常,只是在配送方式修改时会出现\includes\lib_common.php on line 959错误。不确定是什么问题。不知道是不是php
5.3的原因。
解决方法是修改lib_common.php 959行代码

将代码:
$price = number_format($price, 2, '.', '');
修改为
$price = number_format((double)$price, 2, '.', '');
问题解决了。

et_highlighter51

添加新评论

| 0个评论
Rss / Top
Copyright © 2010-2013 / Powered by emlog / Theme by cho
Don't forget transplant by LaoLuo!
沪ICP备09043509号 sitemap